Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Quest 2 Gamepad pairing troubles
Hi Everyone,

I just updated from a Quest 1 to a Quest 2. My 1st try with linking the game pad worked great and I got to finally get back into the competition. Today though, it will show up, but the moment it connects, it drops and then stays on 'connecting'  This is regardless of the method used (App or Experimental Settings). I've tried turning off Q2 and pulling the battery for 30 seconds, forgetting the pair and trying again....still not connecting.

Was there an update to Oculus firmware overnight or something or is my gamepad going bad?


More details: I put it in pairing mode and the blue LED flashes. Once it connects, the light turns off. Then it drops and the pairing LED starts flashing again. It does not reconnect though. The only way to reconnect after that point is to forget the pair. It simply does the same thing though.

Quest 1 was factory reset and not powered on btw

Just so you know, there are a few of us having this same issue. Mine is happening the exact same way yours is. I've unpaired it, took the battery out, paired it again, only to have it "connecting" once it pairs. If you haven't seen it, there is a longer thread about this on the forum called "satechi controller not pairing - quest 2


Eric G

Forum Jump:

Users browsing this thread: 1 Guest(s)