Blue Overlay Glitch - Printable Version

+- (
+-- Forum: VZfit Forum (
+--- Forum: General Discussion (
+--- Thread: Blue Overlay Glitch (/showthread.php?tid=400)

Pages: 1 2

Blue Overlay Glitch - mguerena - 08-09-2020

I experienced a glitch that I had not seen before. I was not sure if it was just from the route I was taking, but it also was overlaid on the screen when I changed to a new route. 

It occurred about 15-20 minutes after I finished the route I created and was doing a free form ride traveling away from the end point. When I quit and restarted the app, it cleared up but I was sadly unable to pick up from where I left off on the free ride I was doing. 

I uploaded a video to YouTube so you can see what happened on the screen.

Here is a screenshot as well.

RE: Blue Overlay Glitch - spyder17 - 08-09-2020

Yep, same thing I still get. Was beginning to think I was the only one getting this.

RE: Blue Overlay Glitch - emalafeew - 08-10-2020

Spyder just sent you a private message about testing a special build, since you get the problem most regularly.

mguerena this is pretty rare and we don't have a solid repro, but we know it doesn't happen in City Mode and "fixes itself" if you stop pedaling and hold B/Y to bring up the high-res view. We're trying to learn more about it, so if it happens again let us know if you want to test our special build too.

RE: Blue Overlay Glitch - mguerena - 08-15-2020

It happened once more this week. Can’t remember the location I was riding. My fix is I load up Play and then go back to Explorer it resolves it.

RE: Blue Overlay Glitch - emalafeew - 08-17-2020

(08-15-2020, 10:47 PM)mguerena Wrote: It happened once more this week. Can’t remember the location I was riding. My fix is I load up Play and then go back to Explorer it resolves it.

People have reported that changing to City mode and back will also fix it.  It only seems to happen in Country mode.

RE: Blue Overlay Glitch - surfous - 08-17-2020

Hey Eric,

I’d be happy to test the special build for tracking this. I get the blue blob of... blobbiness about every other day.

FWIW, I haven’t yet tried hi-res view to clear it - I just read about that in this thread a moment ago. I have tried switching to city mode and back, and that does not clear it for me. Quitting explorer and restarting doesn’t clear it for me, either. So far, I have to restart my quest in order to clear it.

RE: Blue Overlay Glitch - KevinBrook - 08-17-2020

I completed two of the VRFS rides today and had no problems. In fact, I've not had the blue screen at all in VZfit but I have had it on Holodia's Holofit on my last two rows that was very distracting as I couldn't see the screen and it was flickering blue the whole time. There's also lots of complaints on the FitXR group page that people are experiencing it there so could be something related to an Oculus software update.

RE: Blue Overlay Glitch - emalafeew - 08-18-2020

With spyder's help we've narrowed it down to our mid-frame z-buffer clear in Country Mode, which is perfectly valid to do, but a recent Oculus optimization or pipeline change doesn't like after a while somehow. Not having that mid-frame clear causes certain artifacts but does seem to avoid the problem.

The reason for the problem is definitely beneath our game, but knowing what triggers it may be help us accomplish the same need a different way. We had already suspected the z-buffer and tried changing how we clear it a month ago, and also updated to the latest versions of Unity and Oculus SDK, to no avail.

RE: Blue Overlay Glitch - surfous - 08-18-2020

I did try entering the high-res view after I got blobbed today - while it goes away in high-res view, it comes right back as soon as I let go of the B button.

It makes sense that it's at the oculus level since I have to restart my headset to get it to go away, even though it only shows in explorer in country mode. If I quit explorer and relaunch, the blob will be there waiting for me.

Here's hoping that Oculus or Unity can help!

RE: Blue Overlay Glitch - emalafeew - 08-22-2020

Our latest hotfix today disables an Oculus optimization that could possibly have led to these blue blobs. Anyone please report here if you see them again on today's build or later.